Technical Requirements

SWITCHcast annotate! requires you to have a SWITCHaai Login.

Supported web browsers:

  • Firefox 3.6 or higher
  • Internet Explorer 9 or higher
  • Safari 5 or higher
  • Chrome 14 or higher

A quick way to find out whether you meet all the requirements is to launch the SWITCHcast annotate! Demo.