SWITCHdrive clients

  Download (Version 2.7.6 - 64bit)

  Download (Version 2.7.6 - 32bit)

(Requirements: Windows 7 or newer) 

Visit the installation Instructions

  Download (Version 2.7.6)

(Requirements: OSX 10.12 Sierra or newer)

Visit the installation instructions 

As we don't provide a branded SWITCHdrive Sync Client for Linux, download and install the ownCloud Sync Client from here.

Requirements: 

  • CentOS 7.6+ & 8

  • Debian 9.0 & 10

  • Fedora 30 & 31 & 32

  • Ubuntu 18.04 & 19.04 & 19.10 & 20.04

  • openSUSE Leap 15.0 & 15.1 & 15.2

 Get the App from the AppStore

 

Visit the installation Instructions

Get the App from the PlayStore

 

Visit the installation Instructions